Skip to main content

RSA System Requirements

Tools

The RSA deployment Helm chart has been tested with Helm 2.X as well as 3.X. Kubernetes versions supported include 13.X, 14.X, 15.X, 16.X.

Resources

A working Kubernetes cluster is required in order to install a Resource Server Adapter. The exact sizing of this cluster can vary depending on the specific deployment needs, but the bare minimum should include a single node with 1 vCPU and 1GB of RAM of available resources to dedicate to the FPX components. If the required configuration dictates that MySQL needs to be deployed as well, an additional 0.5 vCPU and 0.5GB of RAM should be allocated.

Kubernetes Components

As FPX is packaged as a Helm chart, if you are using a version of Helm < 3.X, you will need to ensure that the tiller pod is initialized before continuing (Refer to Using Helm for details).

An Ingress controller of some kind must be available within the network in order for external network traffic to reach the application pods running within Kubernetes. At this time, the only officially supported ingress controller is NGINX Ingress Controller for Kubernetes. It is also recommended that a namespace is created within your cluster where FPX will be installed. Within that namespace, a secret must be created that contains the docker-container repository credentials used during installation.